This project has moved and is read-only. For the latest updates, please go here.

Windows 10 splashscreen

Sep 7, 2015 at 4:15 PM
Edited Sep 7, 2015 at 4:16 PM
Hi, I just want to ask for little help.
I'm using DXTK in our app as a canvas where our multiplatform engine draw and everything works fine, except Win10. When app starts, it seems OK and loop is calling Render/Present without any errors, but splash screen does not disappearer. Same code on Windows Phone 8.1 works just fine.

Here are some swapChain settings:
 DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
    swapChainDesc.Width = static_cast<UINT>(m_renderTargetSize.Width);
    swapChainDesc.Height = static_cast<UINT>(m_renderTargetSize.Height);
    swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
    swapChainDesc.Stereo = false; 
    swapChainDesc.SampleDesc.Count = 1; 
    swapChainDesc.SampleDesc.Quality = 0;
    swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
    swapChainDesc.BufferCount = 2;  
    swapChainDesc.Scaling = DXGI_SCALING_NONE;                
    swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;
    swapChainDesc.Flags = 0;
then I update ID3D11Texture2D with new buffer (UpdateSubresource1()),
draw ID3D11ShaderResourceView texture to spriteBach
and then present (Present1()), but nothing happen

I'm not sure if this part of code can help, but can anyone advice me on what part should I focus?
Thanks
Sep 7, 2015 at 9:48 PM
By "on Windows 10" do you mean a universal Windows app? If so, you might want to take a look at the Direct3D UWP Game VS Template.