This project has moved and is read-only. For the latest updates, please go here.

Mipmap problems with CreateDDSTextureFromFile (solved)

Nov 6, 2012 at 8:48 AM

I'm getting artifacts in my terrain when loading textures with CreateDDSTextureFromFile. The dds file contains mipmaps, and it worked with the D3DX texture loader. When I converted the texture to png and loaded it with CreateWICTextureFromFile it works.

Is there anything I need to consider regarding mipmaps when using CreateDDSTextureFromFile?

Any ideas?

Link to a gamedev thread in case you need details:

Nov 6, 2012 at 7:50 PM

Can you share one of your .DDS files? CreateDDSTextureFromFile should defintely be loading your image with mipmaps intact.

Nov 6, 2012 at 8:08 PM

Well, this is embarrassing. It seems like the dds tool I used showed that the dds file had mipmaps, but when I opened it in gimp and generated mipmaps everything seems to work well. Either the file had corrupt mimaps, or the tool is defective.

Thanks for the answer though, and thanks for the good libraries.